Чтобы составить список уникальных значений с помощью формулы нужно:

1. Скопировать значения в ячейки А2,А3…

2. Вставить в ячейку B3 формулу:

=ЕСЛИОШИБКА(ИНДЕКС(A2:A13;ПОИСКПОЗ(СУММ(СЧЁТЕСЛИ(B$2:B2;A2:A13));СЧЁТЕСЛИ(A2:A13;»<«;A2:A13);0));»»)

завершить формулу нажав Ctrl+Shift+Enter

3.Скопировать ячейку B3 в ячейки B4, B5, … до конца списка уникальных значений.

 

Давайте разберемся, как работает формула:

  1. СЧЁТЕСЛИ(А2:А13;»<«&А2:А13) – возвращает массив (1) с количеством сотрудников, которые меньше сотрудника, находящегося в текущей ячейке. Т.е. массив будет иметь вид {5; 20; 19; 21; 12 …}. Таким образом, мы получаем что-то наподобие отсортированного листа.
  2. СЧЁТЕСЛИ(B$1:B…;А2:А13) – возвращает массив (2) с единицами для тех позиций, которые уже имеются на отсортированном листе. Например, в ячейке B2 будет массив {0;0;0;0;0…}, а в ячейке B8 — {0;1;0;0;0; … ;0;1}.
  3. СУММ – суммирует значения, которые уже были представлены на отсортированном списке.
  4. ПОИСКПОЗ – ищет сумму встречающихся значений массива (2) в массиве (1)
  5. ЕСЛИОШИБКА – скрывает #Н/А, когда расчеты достигают конца списка.
  6. Источник

[свернуть]